Lançado o KDE Frameworks 5.21.0, Qt 5.4 ou superior agora é necessário


O projeto KDE anunciou neste sábado (09) mais uma nova atualização de manutenção para o KDE Frameworks 5, a 5.21.0, para o ambiente gráfico KDE Plasma 5.6. Esta versão traz inúmeras melhorias para a coleção de mais de 70 bibliotecas add-on para o Qt, o open source e GUI (Graphical User Interface) multiplataforma kit de ferramentas usadas por milhões de desenvolvedores em todo o mundo.

"O KDE anuncia hoje o lançamento do KDE Frameworks 5.21.0. Este lançamento é parte de uma série de lançamentos mensais planejados que fazem com que melhorias estejam disponíveis para os desenvolvedores de uma forma rápida e previsível", diz o anúncio oficial.

Sendo lançado exclusivamente para a última versão estável disponível do ambiente gráfico do projeto, o KDE Plasma 5.6.2, a maior mudança parece ser a descontinuação do suporte para a antiga série Qt 5.3, exigindo que todos os frameworks passem a usar o Qt 5.4 ou posterior (a última versão estável do Qt é a 5.6). Mas, de acordo com as notas de lançamento, há melhorias para o Plasma Framework, NetworkManagerQt, KWidgetsAddons, KXMLGUI, KTextEditor, KService, KRunner e KPeople.

Além disso, componentes como Package Framework, KNotification, KNewStuff, KItemModels, KIO, KInit, KI18n, KGlobalAccel, KEmoticons, KDESU, KDeclarative, KDELibs 4, KDBusAddons, KCoreAddons, KConfig, KCompletion, KCodecs, KActivities, os ícones Breeze e Oxygen, BluezQt, Baloo, e Attica também receberam melhorias.

Por último, há módulos CMake extras e várias correções de bugs para a integração Framework. O KDE Frameworks 5.21.0 é uma atualização recomendada para todos os usuários que possuem o KDE Plasma 5.6, portanto, fique ligado para uma futura atualização.


FONTE: Softpedia | KDE

COMENTÁRIOS