Driver open source para placas AMD Radeon HD 5800 e 6900 está a um passo do OpenGL 4.5


Não aconteceu a tempo para o próximo Mesa 18.0, mas o driver Gallium3D R600, que lida com GPUs AMD Radeon pré-GCN na plataforma Linux, agora está quase em conformidade com o OpenGL 4.5. Uma extensão OpenGL 4.4 necessária na lista que completa as extensões necessárias para efetivamente ter o GL 4.5 está marcada para ser implementada, assegurando que o driver de vídeo pode passar no conjunto de testes de conformidade da API gráfica.

Recentemente, David Airlie, da Red Hat, um dos poucos desenvolvedores interessados nas melhorias de recursos para modelos mais antigos de placas de vídeo da AMD, publicou um conjunto de patches que permitem o suporte para a ARB_query_buffer_object. Esta extensão fornece estatísticas sobre a operação do pipeline OpenGL, porém, o mais emocionante para o usuário final é que esta foi a extensão GL 4.4/4.5 final necessária para que as placas AMD das séries Radeon HD 5800 e 6900 suportem o OpenGL 4.5.

Mas, antes que você fique muito animado, este suporte quase completo do OpenGL 4.5 não é para todo o hardware pré-GCN (série HD 7000). No momento, o OpenGL 4.x com o driver R600 só está disponível, como já tínhamos mencionado no parágrafo acima, para as séries Radeon HD 5800 e HD 6900. As outras placas no momento estão limitadas ao OpenGL 3.3 por não terem o suporte para a extensão ARB_gpu_shader_fp64 no nível de hardware. Felizmente, existe um trabalho contínuo para o suporte ao FP64 a nível de software que permitirá que essas outras GPUs Radeon entrem no mundo OpenGL 4.x.

Espera-se que o suporte para o OpenGL 4.5 com essas GPUs esteja pronto a tempo para o lançamento do Mesa 18.1 no próximo trimestre, pouco mais de um ano após o OpenGL 4.5 ter sido alcançado para o driver mais novo RadeonSI.


FONTE: Phoronix
IMAGEM: Phoronix

Comentários