Veja como obter suporte para a Vulkan no Ubuntu com GPU AMD ou Intel


Infelizmente, o suporte para a Vulkan com GPUs AMD ou Intel ainda não está presente por padrão no Ubuntu. A decisão da Canonical de não incluir esse suporte por padrão no seu sistema operacional é, no mínimo, estranha especialmente quando levamos em consideração que cada vez mais os novos lançamentos de jogos para Linux usam a API gráfica como, por exemplo, F1 2017 e Rise of the Tomb Raider: 20 Year Celebration.

Obtendo suporte para a Vulkan no Ubuntu com GPUs AMD ou Intel

Obter suporte para a Vulkan no Ubuntu com placas de vídeo AMD ou com os gráficos integrados da Intel é algo bem simples. Basta que você instale os pacotes mesa-vulkan-driversvulkan-utilslibassimp4, algo que pode ser feito pelo gerenciador de softwares Synaptic, aplicativo que pode ser instalado agora mesmo clicando aqui ou através da loja de apps Ubuntu Software.

Para instalar os pacotes mencionados acima, basta pesquisar por eles no Synaptic, marcando cada um deles para a instalação, clicando com o botão direito do mouse e selecionando "Marcar para a instalação" ou dando um duplo clique sobre os pacotes. Você também pode simplesmente executar no Terminal:   sudo apt install mesa-vulkan-drivers vulkan-utils libassimp4  .


Vale ressaltar que nem todos os modelos de GPUs da AMD ou de processadores da Intel, com os seus gráficos Integrados, possuem suporte para a Vulkan. No caso da AMD, placas de vídeo RX 200 (Volcanic Islands) e mais recentes possuem suporte para a Vulkan no Linux. Já GPUs Radeon HD 7000 (Southern Islands (SI) e Sea Islands (CIK)) possuem apenas suporte experimental, que está desabilitado por padrão.

No caso da Intel, o suporte está disponível para gráficos Ivy Bridge "Gen 3" e mais recente. Com os drivers Vulkan devidamente instalados no seu Ubuntu, você pode obter informações técnicas da API executando no Terminal:   vulkaninfo  , o que também é útil para saber se o suporte está habilitado.
Comentários