Devs do Arch Linux querem instalações com Pacman mais rápidas usando o Zstd


A próxima versão do Pacman, a 5.2, trará suporte para a compactação de pacotes com Zstd (Zstandard), o algoritmo de compressão de dados sem perdas do Facebook, o que, em última análise, fornecerá instalações de pacotes mais rápidas no Arch Linux, que agora está seguindo os mesmos passos de outras distribuições Linux que adotaram o Zstd e estão tendo bons resultados.

De acordo com um comunicado publicado nesta quarta-feria (16) pelos desenvolvedores da distribuição Linux, os usuários precisaram ter instalada uma versão atualizada da biblioteca libarchive, que traz suporte para o Zstd.

"Para instalar pacotes [com o Pacman 5.2], você precisará da libarchive com suporte a zstd, que entrou nos repositórios em setembro de 2018. Para que os pacotes compactados com zstd sejam distribuídos, exigimos que todos os usuários tenham atualizado para, pelo menos, a libarchive 3.3.3-1. Você teve um ano, então esperamos que você já tenha atualizado. Apresse-se se não tiver", diz os desenvolvedores.

Então, se por algum motivo você estiver executando uma instalação do Arch Linux com a biblioteca libarchive muito desatualizada, será necessário atualizar em breve para evitar problemas no futuro.


FONTE: Phoronix
Tags :
Comentários